Jose Armando Garcia Sancio created KAFKA-12982:
--------------------------------------------------

             Summary: Notify listeners of raft client shutdowns
                 Key: KAFKA-12982
                 URL: https://issues.apache.org/jira/browse/KAFKA-12982
             Project: Kafka
          Issue Type: Sub-task
            Reporter: Jose Armando Garcia Sancio


`RaftClient.Listener.beginShutdown` should be called when the `RaftClient` is 
shutting down. I think there should be two ways to terminate the `RaftClient`. 
Those are `shutdown` and `close`.

It looks like the current code for `close` only closes the metrics registry. It 
doesn't notify the listeners that the raft client was close. It doesn't stop 
future `poll` from updating the raft client.

There is also an assumption that `shutdown` can only be called once. I think to 
satisfy this we should remove this method from `RaftClient` and keep it as 
implementation method in `KafkaRaftClient`.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Reply via email to