[ 
https://issues.apache.org/jira/browse/KAFKA-1171?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13893674#comment-13893674
 ] 
Neha Narkhede edited comment on KAFKA-1171 at 2/6/14 7:17 PM:
--------------------------------------------------------------

Few more comments -

1. Is it gradle naming convention to have "_" in the task names. For example, 
test_all instead of just testall?
2. It is worth trying Jakob's suggestion above as that will improve readability 
of tests
3. uploadArchives fails probably because the maven url doesn't exist. But the 
README should have instructions on how to test it 
Uploading: org/apache/kafka/kafka_2.10.1/0.8.1/kafka_2.10.1-0.8.1.jar to 
repository remote at http://your.maven.repository
Error transferring file
:kafka:core:uploadArchives FAILED
:uploadCoreArchives_2_10_1 FAILED
FAILURE: Build failed with an exception.
* What went wrong:
Execution failed for task ':core:uploadArchives'.
> Could not publish configuration 'archives'
   > Error deploying artifact 'org.apache.kafka:kafka_2.10.1:jar': Error 
deploying artifact: Error transferring file
4. ./gradlew test_all has some test failures -
kafka.producer.ProducerTest > testUpdateBrokerPartitionInfo FAILED
    junit.framework.AssertionFailedError at ProducerTest.scala:91
> Building > :test_core_2_10_1 > :kafka:core:test > 177 tests completed, 1 
> failed
8 tests completed, 1 failed
224 tests completed, 1 failed
:kafka:core:test FAILED
:test_core_2_10_1 FAILED
FAILURE: Build failed with an exception.
* What went wrong:
Execution failed for task ':core:test'.
> There were failing tests. See the report at: 
> file:///home/nnarkhed/Projects/kafka/core/build/reports/tests/index.html




was (Author: nehanarkhede):
+1 on the latest patch. Few minor comments -

1. Is it gradle naming convention to have "_" in the task names. For example, 
test_all instead of just testall?
2. It is worth trying Jakob's suggestion above as that will improve readability 
of tests

> Gradle build for Kafka
> ----------------------
>
>                 Key: KAFKA-1171
>                 URL: https://issues.apache.org/jira/browse/KAFKA-1171
>             Project: Kafka
>          Issue Type: Improvement
>          Components: packaging
>    Affects Versions: 0.8.1, 0.9.0
>            Reporter: David Arthur
>            Assignee: David Arthur
>            Priority: Blocker
>         Attachments: 0001-Adding-basic-Gradle-build.patch, 
> 0001-Adding-basic-Gradle-build.patch, 0001-Adding-basic-Gradle-build.patch, 
> 0001-Adding-basic-Gradle-build.patch, 0001-Adding-basic-Gradle-build.patch, 
> 0001-Adding-basic-Gradle-build.patch, 0001-Adding-basic-Gradle-build.patch, 
> kafka-1171_v10.patch, kafka-1171_v11.patch, kafka-1171_v12.patch, 
> kafka-1171_v13.patch, kafka-1171_v14.patch, kafka-1171_v6.patch, 
> kafka-1171_v7.patch, kafka-1171_v8.patch, kafka-1171_v9.patch
>
>
> We have previously discussed moving away from SBT to an 
> easier-to-comprehend-and-debug build system such as Ant or Gradle. I put up a 
> patch for an Ant+Ivy build a while ago[1], and it sounded like people wanted 
> to check out Gradle as well.
> 1. https://issues.apache.org/jira/browse/KAFKA-855



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Reply via email to