-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/15674/#review30456
-----------------------------------------------------------



core/src/main/scala/kafka/cluster/Partition.scala
<https://reviews.apache.org/r/15674/#comment58264>

    I'm guessing this change shouldn't be in this patch



core/src/main/scala/kafka/cluster/Partition.scala
<https://reviews.apache.org/r/15674/#comment58265>

    same here



core/src/main/scala/kafka/common/AllDoneException.scala
<https://reviews.apache.org/r/15674/#comment58266>

    can we please rename AllDone to something meaningful?



core/src/main/scala/kafka/log/LogCleaner.scala
<https://reviews.apache.org/r/15674/#comment58268>

    Can we rename inProgress to cleaningInProgress?



core/src/main/scala/kafka/log/LogCleaner.scala
<https://reviews.apache.org/r/15674/#comment58269>

    I think these case objects should be named more descriptively to 
communicate that they are related to log cleaning. For example, InProgress -> 
LogCleaningInProgress. Makes the code much more readable. Similarly 
PausingLogCleaning and LogCleaningPaused



core/src/main/scala/kafka/common/PausingCleaningException.scala
<https://reviews.apache.org/r/15674/#comment58267>

    PausingCleaningException => PausedCleaningException on the lines of 
CancelledCleaningException


- Neha Narkhede


On Dec. 16, 2013, 5:43 p.m., Jun Rao wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/15674/
> -----------------------------------------------------------
> 
> (Updated Dec. 16, 2013, 5:43 p.m.)
> 
> 
> Review request for kafka.
> 
> 
> Bugs: KAFKA-1074
>     https://issues.apache.org/jira/browse/KAFKA-1074
> 
> 
> Repository: kafka
> 
> 
> Description
> -------
> 
> Summary of changes since the previous patch.
> 
> LogCleaner:
> * Added the logic to pause and resume the cleaning of a log. Canceling the 
> cleaning is implemented as pausing, followed by resuming.
> 
> LogManager:
> * Don't halt when background flush hits an IOException since the same 
> IOException will be hit during log append, which will halt the broker. This 
> removes the need to synchronize btw the flushing and the deleting of the log.
> * Removed OptimisticLockFailureException in LogCleaner. When a log needs to 
> be truncated, first pause log cleaning, then truncate the log, and finally 
> resume log cleaning.
> 
> 
> Diffs
> -----
> 
>   core/src/main/scala/kafka/cluster/Partition.scala 
> 5c9307d71641ccc6c09a54b69d5aa2b4bc2a4cde 
>   core/src/main/scala/kafka/common/OptimisticLockFailureException.scala 
> 0e69110e71667ad75a460534f4422a7b6ec1cdc6 
>   core/src/main/scala/kafka/common/PausingCleaningException.scala 
> PRE-CREATION 
>   core/src/main/scala/kafka/log/Log.scala 
> beda421b558544196379bd9ab7855cea7614e8e3 
>   core/src/main/scala/kafka/log/LogCleaner.scala 
> ccde2abd99d2204775e4d3e9836aca34eb6747a3 
>   core/src/main/scala/kafka/log/LogManager.scala 
> 81be88aa618ed5614703d45a0556b77c97290085 
>   core/src/main/scala/kafka/server/ReplicaFetcherThread.scala 
> 715845b167c44268bd7e4b76dfb69199bfb2fad4 
>   core/src/main/scala/kafka/server/ReplicaManager.scala 
> 242c18d47828b7c5e6b1fc219a0f1199fb1f9512 
>   core/src/test/scala/unit/kafka/admin/AdminTest.scala 
> 52d35a3ccc86a66acb57c1138d4f2fea8f4ca4b0 
>   core/src/test/scala/unit/kafka/log/CleanerTest.scala 
> 5a312bf0803c1df4636e2e64ba83036a4e8e92dd 
> 
> Diff: https://reviews.apache.org/r/15674/diff/
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> Jun Rao
> 
>

Reply via email to