[ https://issues.apache.org/jira/browse/HIVE-4844?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13767064#comment-13767064 ]
Xuefu Zhang commented on HIVE-4844: ----------------------------------- Thanks for making so much progress in such a short time. I have some comments while reading the patch. 1. TypeInfoUtils.addParamsToTypeName() seems having duplicated code with VarcharTypeParam.toString().I also saw this in FunctionRegistry, which also has some duplicated logic here. It's nice if we can consolidate and have single point of reference for this. {code} + String typeName = + PrimitiveObjectInspectorUtils.getTypeEntryFromPrimitiveCategory(typeCategory).typeName + + varcharParams.toString(); {code} 2. DDLSemanticAnalyzer.getTypeName() tries to get a list of Strings from the ASTNode by using ParseUtils.getCharParams(), in which only a subset of checks are performed. (For instance, it doesn't validate the MAX allowed length.) Instead, I think it's probably better to get VarcharTypeParams instance from the ASTNode and let the instance perform all the checks. I haven't gone thru the patch yet, but I'd like to share my thoughts. > Add varchar data type > --------------------- > > Key: HIVE-4844 > URL: https://issues.apache.org/jira/browse/HIVE-4844 > Project: Hive > Issue Type: New Feature > Components: Types > Reporter: Jason Dere > Assignee: Jason Dere > Attachments: HIVE-4844.10.patch, HIVE-4844.11.patch, > HIVE-4844.12.patch, HIVE-4844.13.patch, HIVE-4844.14.patch, > HIVE-4844.15.patch, HIVE-4844.16.patch, HIVE-4844.17.patch, > HIVE-4844.1.patch.hack, HIVE-4844.2.patch, HIVE-4844.3.patch, > HIVE-4844.4.patch, HIVE-4844.5.patch, HIVE-4844.6.patch, HIVE-4844.7.patch, > HIVE-4844.8.patch, HIVE-4844.9.patch, HIVE-4844.D12699.1.patch, > HIVE-4844.D12891.1.patch, screenshot.png > > > Add new varchar data types which have support for more SQL-compliant > behavior, such as SQL string comparison semantics, max length, etc. > Char type will be added as another task. -- This message is automatically generated by JIRA. If you think it was sent incorrectly, please contact your JIRA administrators For more information on JIRA, see: http://www.atlassian.com/software/jira