----------------------------------------------------------- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/72465/#review220802 -----------------------------------------------------------
Thank you for the patch, Peter! LGTM 1 comment on static import + 1 ask to refactor. standalone-metastore/metastore-server/src/main/java/org/apache/hadoop/hive/metastore/txn/CompactionTxnHandler.java Lines 40 (patched) <https://reviews.apache.org/r/72465/#comment309502> Up to you, but I wouldn't use static import. standalone-metastore/metastore-server/src/main/java/org/apache/hadoop/hive/metastore/txn/TxnHandler.java Line 1037 (original), 905 (patched) <https://reviews.apache.org/r/72465/#comment309500> I wouldn't use static import here, but TxnStatus.OPEN instead to be consistent and I think it's more clear what 'OPEN' is related to (previously it was TXN_OPEN). standalone-metastore/metastore-server/src/main/java/org/apache/hadoop/hive/metastore/txn/TxnStatus.java Lines 32 (patched) <https://reviews.apache.org/r/72465/#comment309501> Could you please refactor here as well LockTypeUtil to LockType enum. - Denys Kuzmenko On May 7, 2020, 11:58 a.m., Peter Varga wrote: > > ----------------------------------------------------------- > This is an automatically generated e-mail. To reply, visit: > https://reviews.apache.org/r/72465/ > ----------------------------------------------------------- > > (Updated May 7, 2020, 11:58 a.m.) > > > Review request for hive and Denys Kuzmenko. > > > Repository: hive-git > > > Description > ------- > > * Merge getOpenTxns and getOpenTxnInfo to avoid code duplication > * Remove TxnStatus character constants and use the enum values > > > Diffs > ----- > > > standalone-metastore/metastore-server/src/main/java/org/apache/hadoop/hive/metastore/txn/CompactionTxnHandler.java > d59f863b11 > > standalone-metastore/metastore-server/src/main/java/org/apache/hadoop/hive/metastore/txn/OpenTxn.java > PRE-CREATION > > standalone-metastore/metastore-server/src/main/java/org/apache/hadoop/hive/metastore/txn/OpenTxnList.java > PRE-CREATION > > standalone-metastore/metastore-server/src/main/java/org/apache/hadoop/hive/metastore/txn/OperationType.java > PRE-CREATION > > standalone-metastore/metastore-server/src/main/java/org/apache/hadoop/hive/metastore/txn/TxnHandler.java > 7c3937520c > > standalone-metastore/metastore-server/src/main/java/org/apache/hadoop/hive/metastore/txn/TxnStatus.java > PRE-CREATION > > > Diff: https://reviews.apache.org/r/72465/diff/3/ > > > Testing > ------- > > > Thanks, > > Peter Varga > >