----------------------------------------------------------- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/47426/#review142666 -----------------------------------------------------------
ql/src/java/org/apache/hadoop/hive/ql/exec/FileSinkOperator.java (lines 598 - 602) <https://reviews.apache.org/r/47426/#comment208295> Permissions should be sent from compiler in query plan. There is no need to compute/cache at runtime. ql/src/java/org/apache/hadoop/hive/ql/exec/FileSinkOperator.java (line 672) <https://reviews.apache.org/r/47426/#comment208296> Missed ! in if() ? or variable name is confusing :) ql/src/java/org/apache/hadoop/hive/ql/io/HiveOutputFormatWithPermission.java (line 31) <https://reviews.apache.org/r/47426/#comment208298> Better name: HiveOutputFormatV2 ? We may add more methods in it later. ql/src/java/org/apache/hadoop/hive/ql/io/HivePassThroughOutputFormat.java (lines 84 - 85) <https://reviews.apache.org/r/47426/#comment208299> No caller for this. Can be removed. ql/src/java/org/apache/hadoop/hive/ql/parse/SemanticAnalyzer.java (line 7030) <https://reviews.apache.org/r/47426/#comment208300> Any reason for checking NOT_ACID? ql/src/java/org/apache/hadoop/hive/ql/parse/SemanticAnalyzer.java (lines 7046 - 7048) <https://reviews.apache.org/r/47426/#comment208301> Here is where we may collect target perms we want to set. ql/src/java/org/apache/hadoop/hive/ql/plan/FileSinkDesc.java (line 99) <https://reviews.apache.org/r/47426/#comment208302> We should be storing target permissions rather. - Ashutosh Chauhan On June 8, 2016, 10:35 p.m., pengcheng xiong wrote: > > ----------------------------------------------------------- > This is an automatically generated e-mail. To reply, visit: > https://reviews.apache.org/r/47426/ > ----------------------------------------------------------- > > (Updated June 8, 2016, 10:35 p.m.) > > > Review request for hive and Ashutosh Chauhan. > > > Repository: hive-git > > > Description > ------- > > HIVE-13662 > > > Diffs > ----- > > > itests/hive-unit/src/test/java/org/apache/hadoop/hive/ql/security/TestFolderPermissions.java > 6cc2d18 > orc/src/java/org/apache/orc/OrcFile.java 7dd7333 > orc/src/java/org/apache/orc/impl/WriterImpl.java b2966e0 > ql/src/java/org/apache/hadoop/hive/ql/exec/FileSinkOperator.java 0ac9109 > ql/src/java/org/apache/hadoop/hive/ql/exec/MoveTask.java aeaae6b > ql/src/java/org/apache/hadoop/hive/ql/exec/Utilities.java 528d663 > ql/src/java/org/apache/hadoop/hive/ql/io/HiveBinaryOutputFormat.java > 31788dd > ql/src/java/org/apache/hadoop/hive/ql/io/HiveFileFormatUtils.java 6bb5efa > ql/src/java/org/apache/hadoop/hive/ql/io/HiveIgnoreKeyTextOutputFormat.java > 9ad7f37 > > ql/src/java/org/apache/hadoop/hive/ql/io/HiveOutputFormatWithPermission.java > PRE-CREATION > ql/src/java/org/apache/hadoop/hive/ql/io/HivePassThroughOutputFormat.java > 5855288 > ql/src/java/org/apache/hadoop/hive/ql/io/RCFile.java d391164 > ql/src/java/org/apache/hadoop/hive/ql/io/RCFileOutputFormat.java 479f198 > > ql/src/java/org/apache/hadoop/hive/ql/io/avro/AvroContainerOutputFormat.java > 59d3bba > ql/src/java/org/apache/hadoop/hive/ql/io/orc/OrcOutputFormat.java b0f8c8b > ql/src/java/org/apache/hadoop/hive/ql/metadata/Hive.java 2b01fce > ql/src/java/org/apache/hadoop/hive/ql/optimizer/GenMapRedUtils.java 7595065 > ql/src/java/org/apache/hadoop/hive/ql/parse/SemanticAnalyzer.java cd3c860 > ql/src/java/org/apache/hadoop/hive/ql/plan/FileSinkDesc.java 07ed4fd > ql/src/java/org/apache/hadoop/hive/ql/plan/LoadFileDesc.java df153a2 > ql/src/java/org/apache/hadoop/hive/ql/plan/LoadTableDesc.java 771a919 > ql/src/java/org/apache/hadoop/hive/ql/plan/MoveWork.java 9f498c7 > shims/common/src/main/java/org/apache/hadoop/hive/io/HdfsUtils.java 70a6857 > > Diff: https://reviews.apache.org/r/47426/diff/ > > > Testing > ------- > > > Thanks, > > pengcheng xiong > >
