> On Feb. 2, 2015, 7:31 p.m., John Pullokkaran wrote: > > ql/src/java/org/apache/hadoop/hive/ql/optimizer/index/RewriteQueryUsingAggregateIndexCtx.java, > > line 279 > > <https://reviews.apache.org/r/29763/diff/6/?file=839088#file839088line279> > > > > This optimization is trying to get at the first GB after scan right? > > i.e should we be traversing down stream or upstream?
First we get the top operator out of the query. Then we go down the tree till we find the last GroupBy operator i.e. the first one after the Scan. But in Hive operator tree, down the tree = upstream; that is why I call the getParents method. - Jesús ----------------------------------------------------------- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/29763/#review70607 ----------------------------------------------------------- On Jan. 28, 2015, 7:05 p.m., Jesús Camacho Rodríguez wrote: > > ----------------------------------------------------------- > This is an automatically generated e-mail. To reply, visit: > https://reviews.apache.org/r/29763/ > ----------------------------------------------------------- > > (Updated Jan. 28, 2015, 7:05 p.m.) > > > Review request for hive and John Pullokkaran. > > > Bugs: HIVE-9292 > https://issues.apache.org/jira/browse/HIVE-9292 > > > Repository: hive-git > > > Description > ------- > > CBO (Calcite Return Path): Inline GroupBy, Properties > > > Diffs > ----- > > > ql/src/java/org/apache/hadoop/hive/ql/optimizer/index/RewriteParseContextGenerator.java > 3097385b92d4398ee57d3544354b383fe24719dd > > ql/src/java/org/apache/hadoop/hive/ql/optimizer/index/RewriteQueryUsingAggregateIndexCtx.java > 69a5a4409164fc6cb725b315de08ec9d090b7f22 > ql/src/java/org/apache/hadoop/hive/ql/parse/ParseContext.java > dda4f75592209d88f25b5ca09ea9f32c77ea4ac6 > ql/src/java/org/apache/hadoop/hive/ql/parse/SemanticAnalyzer.java > c9a5ce53ffc3d5c791e0826be0cac771a4d20254 > ql/src/java/org/apache/hadoop/hive/ql/parse/TaskCompiler.java > 0116c85979f02ea0f88bbf8085a7590694eb2dfb > > Diff: https://reviews.apache.org/r/29763/diff/ > > > Testing > ------- > > Existing tests. > > > Thanks, > > Jesús Camacho Rodríguez > >