[ https://issues.apache.org/jira/browse/HIVE-1916?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13082032#comment-13082032 ]
jirapos...@reviews.apache.org commented on HIVE-1916: ----------------------------------------------------- ----------------------------------------------------------- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/1441/ ----------------------------------------------------------- (Updated 2011-08-10 00:56:44.290697) Review request for hive and Ning Zhang. Changes ------- Added hive.autogen.columnname.prefix.label and hive.autogen.columnname.prefix.includefuncname to hive-default.xml Created a static final variable for the 20 char length limit in SemanticAnalyzer.java Took out default variable values from SemanticAnalyzer.java (will be set in constructor) Fixed checkstyle line length warnings introduced by patch in HiveConf.java, SemanticAnalyzer.java Added some more comments in SemanticAnalyzer.java Summary ------- Default behavior will be as before. Adding new Hive conf vars to make the column names include the aggregation function and params. This addresses bug HIVE-1916. https://issues.apache.org/jira/browse/HIVE-1916 Diffs (updated) ----- trunk/common/src/java/org/apache/hadoop/hive/conf/HiveConf.java 1155181 trunk/conf/hive-default.xml 1155181 trunk/ql/src/java/org/apache/hadoop/hive/ql/parse/SemanticAnalyzer.java 1155181 trunk/ql/src/test/queries/clientpositive/autogen_colname.q PRE-CREATION trunk/ql/src/test/results/clientpositive/autogen_colname.q.out PRE-CREATION Diff: https://reviews.apache.org/r/1441/diff Testing ------- Added new query file with expected results. All unit tests pass Thanks, sameerm > Change Default Alias For Aggregated Columns (_c1) > ------------------------------------------------- > > Key: HIVE-1916 > URL: https://issues.apache.org/jira/browse/HIVE-1916 > Project: Hive > Issue Type: Improvement > Components: Query Processor > Environment: All > Reporter: James Mayfield > Priority: Minor > > Problem: > When running a Hive query that aggregates (does a group by operation), Hive > will automatically name this column _c0, _c1, _c2, etc.. This is a problem > because Hive will not then execute a query against a column that begins with > "_" and then the user has to manually input back-ticks in order to get the > query to run. > Potential Solution: > Hive should by default call these columns by their query assignment like > "sum_active30day_users" or if that is not possible, call it something simple > like "column_1" so that users can then query the new column without adding > special back-ticks. > Example Query: > SELECT a.ds, COUNT(a.num_accounts) > Example Result: > ds, count_num_accounts OR ds, column_1 -- This message is automatically generated by JIRA. For more information on JIRA, see: http://www.atlassian.com/software/jira