Hi Paul, Søren, Jonny, Thanks for the PR and for the naming discussion.
I am fine with landing the optional JavaFX DSL. On the name, I lean toward `groovyfx` rather than shortening to `fx` / leaning only on a bare `fx` token: on its own, `fx` does not say much, whereas `groovyfx` (in the same spirit as `groovysh` and `groovydoc`) makes the JavaFX link obvious at a glance. If we keep a hyphenated artifact id for packaging, I would still prefer something that keeps the `groovy` + `fx` pairing visible rather than collapsing to a cryptic short form. Happy to help with further review on #2989 as it settles. Cheers, Daniel Sun
