Gyula Fora created FLINK-37617:
----------------------------------

             Summary: StateIterator should not have 2 onNext methods with 
almost the same signature
                 Key: FLINK-37617
                 URL: https://issues.apache.org/jira/browse/FLINK-37617
             Project: Flink
          Issue Type: Bug
          Components: API / DataStream
    Affects Versions: 2.0.0, 2.1.0
            Reporter: Gyula Fora


Both onNext methods take a consumer-like interface which if provided as a 
lambda cannot be distinguished by the compiler in many cases.

We should change the name of one of the methods. Probably the one that returns 
the collection to something like:


<U> StateFuture<Collection<U>> onNextApply(FunctionWithException<T, 
StateFuture<? extends U>, Exception> var1);



--
This message was sent by Atlassian Jira
(v8.20.10#820010)

Reply via email to