By the way, some of the refactors of stage2 need to be done in Flink 1.19.
Because some Public or PublicEvolving classes are using Time class.

Such as: org.apache.flink.api.common.state.StateTtlConfig#newBuilder
is using the org.apache.flink.api.common.time.Time.
And StateTtlConfig is PublicEvolving class.

I can start sorting all usages out later.

Best,
Rui

On Wed, Jan 3, 2024 at 10:37 AM Rui Fan <1996fan...@gmail.com> wrote:

> Thanks Xintong for promoting the progress of Flink 2.0.
>
> If no one minds, I'd like to pick this one: Use Java’s Duration instead of
> Flink’s Time.
> Could I assign FLINK-14068[1] to me?
>
> My expected progress is:
> - Mark org.apache.flink.api.common.time.Time and
>  org.apache.flink.streaming.api.windowing.time.Time
>  as @Deprecated in 1.19 (Must do in 1.19)
> - Refactor all usages of them to Java's Duration(Nice do in 1.19, must do
> in 1.20)
> - Remove them in 2.0
>
> Is this plan reasonable?
>
> [1] https://issues.apache.org/jira/browse/FLINK-14068
>
> Best,
> Rui
>
> On Wed, Jan 3, 2024 at 9:18 AM Xintong Song <tonysong...@gmail.com> wrote:
>
>> Hi devs,
>>
>> The release managers have been tracking the progress of release 2.0 work
>> items. Unfortunately, some of the items are not in good progress, and
>> either don't have a contributor or the original contributor no longer has
>> capacity to work on them. We have already tried reaching out to some
>> developers, but unfortunately don't find many people with capacity.
>>
>> Therefore, we are looking for developers who want to pick them up.
>>
>> Helps are needed on:
>>
>>    - Introduce dedicated MetricsScope
>>    - Rework MetricGroup scope APIs
>>    - Remove MetricGroup methods accepting an int as a name
>>    - Remove brackets around variables
>>    - Drop MetricReporter#open
>>    - Gauge<T> should only take subclasses of Number, rather than
>> everything
>>    - Add MetricGroup#getLogicalScope
>>    - User Java’s Duration instead of Flink’s Time
>>    - Review and refactor the REST API
>>    - Properly handle NaN/Infinity in OpenAPI spec
>>    - Enforce single maxExceptions query parameter
>>    - Drop Yarn specific get rest endpoints
>>    - Review and refactor the metrics implementation
>>    - Attach semantics to Gauges; refactor Counter / Meter to be Gauges
>> with
>>    syntactic sugar on top
>>    - Restructure
>>
>>
>> Please note that:
>>
>>    - For some of the items, the milestones are already given, and there
>>    might be some actions that need to be performed by Flink 1.19. Please
>> be
>>    aware that we are only 3.5 weeks from the 1.19 feature freeze.
>>    - There are also items which don't have any plans / milestones yet. For
>>    such items, we may want to quickly look into them to find out if
>> there's
>>    anything that needs to be done in 1.19.
>>    - See more details on the 2.0 wiki page [1]
>>
>>
>> If these items do not make Flink 1.19, we can discuss later what to do
>> with
>> them, either postpone release 2.0 or exclude them from this major release.
>> But for now, let's first see what we can do by 1.19.
>>
>> Best,
>>
>> Xintong
>>
>>
>> [1] https://cwiki.apache.org/confluence/display/FLINK/2.0+Release
>>
>

Reply via email to