Hi everyone, I want to start a discussion about further improve and simplify our current connector porperty keys, aka WITH options. Currently, we have a 'connector.' prefix for many properties, but they are verbose, and we see a big inconsistency between the properties when designing FLIP-107.
So we propose to remove all the 'connector.' prefix and rename 'connector.type' to 'connector', 'format.type' to 'format'. So a new Kafka DDL may look like this: CREATE TABLE kafka_table ( ... ) WITH ( 'connector' = 'kafka', 'version' = '0.10', 'topic' = 'test-topic', 'startup-mode' = 'earliest-offset', 'properties.bootstrap.servers' = 'localhost:9092', 'properties.group.id' = 'testGroup', 'format' = 'json', 'format.fail-on-missing-field' = 'false' ); The new connector property key set will come together with new Factory inferface which is proposed in FLIP-95. Old properties are still compatible with their existing implementation. New properties are only available in new DynamicTableFactory implementations. You can access the detailed FLIP here: https://cwiki.apache.org/confluence/display/FLINK/FLIP-122%3A+New+Connector+Property+Keys+for+New+Factory Best, Jark