Hi all, many times I had the feeling that allowing Row.setField() to return the modified object instead of void would really make the (Java) code cleaner in a very unobtrusive way. For example, I could write something like:
DataSet<Row> columnData = input.map(value -> new Row(1).setField(0, value)) instead of: DataSet<Row> columnData = input// .map(value -> { Row r = new Row(1); r.setField(0, value); return r; }) What do you think? May I open a JIRA issue about it? Best, Flavio