Hey guys, I know this should have been part of the PR discussion but it kind of slipped through the cracks :)
I think it might be useful to change the method name for Either.left(value) to Either.Left(value) (or drop the method completely). The reason is that it is slightly awkward to use it with java 8 lambdas. You cannot use Either::left because of the name clash. Maybe it's not a huge issue but a small inconvenience that will come up more often as we are gradually moving to java 8 anyways :) What do you think? Gyula