Just wanted to rephrase my wordings as they seem to be presenting different meaning from what I was intending.
On Tue, Mar 6, 2018 at 12:18 PM, Shreyansh Jain <shreyansh.j...@nxp.com> wrote: > On Tue, Mar 6, 2018 at 7:13 AM, Rosen Xu <rosen...@intel.com> wrote: >> Signed-off-by: Rosen Xu <rosen...@intel.com> >> --- >> drivers/raw/ifpga_rawdev/Makefile | 59 ++++ >> drivers/raw/ifpga_rawdev/ifpga_rawdev.c | 343 >> +++++++++++++++++++++ >> drivers/raw/ifpga_rawdev/ifpga_rawdev.h | 109 +++++++ >> drivers/raw/ifpga_rawdev/ifpga_rawdev_example.c | 121 ++++++++ > > When rawdev skeleton driver was integrated, Thomas raised this point > of naming 'skeleton_rawdev' rather than just 'skeleton'. Thomas questioned why not 'skeleton' and I stuck to 'skeleton_rawdev'. Which, in hindsight, seems to me a bad decision on my part. > So, rather than 'ifpga_rawdev' rather than 'ifpga'. So, rather than 'ifpga_rawdev', why not use 'ifpga'. > At that time I thought we could use <drivertype_driversubtype> as > model. But, frankly, to me it seems a bad choice now. Extra '_rawdev' > doesn't serve any purpose here. > > So, feel free to change your naming to a more appropriate > "drivers/raw/ifpga/" or "drivers/raw/ifpga_sample" etc. > > Probably I too can change the skeleton_rawdev to skeleton. [snip]