On 01/02/2018 07:11 PM, Stefan Hajnoczi wrote:
On Tue, Jan 02, 2018 at 11:27:02AM +0100, Maxime Coquelin wrote:
Hi Stefan,

On 01/02/2018 10:31 AM, Stefan Hajnoczi wrote:
v2:
   * Add internal vhost_vring_call() helper function [Maxime]

These patches eliminate code duplication for vhost_virtqueue->callfd users by
introducing rte_vhost_vring_call() (public API) and vhost_vring_call()
(librte_vhost-internal API).

Stefan Hajnoczi (2):
    vhost: add vhost_vring_call() helper
    vhost: introduce rte_vhost_vring_call()

   lib/librte_vhost/rte_vhost.h           | 15 +++++++++++++++
   lib/librte_vhost/vhost.h               | 12 ++++++++++++
   examples/vhost/virtio_net.c            | 11 ++---------
   examples/vhost_scsi/vhost_scsi.c       |  6 +++---
   lib/librte_vhost/vhost.c               | 21 +++++++++++++++++++++
   lib/librte_vhost/virtio_net.c          | 23 +++--------------------
   lib/librte_vhost/rte_vhost_version.map |  7 +++++++
   7 files changed, 63 insertions(+), 32 deletions(-)


I just wonder whether tagging the new API as experimental is needed,
but apart from that it looks good to me:

Reviewed-by: Maxime Coquelin <maxime.coque...@redhat.com>

 From 3.2. Managing ABI updates, General Guidelines:

   New APIs will be marked as experimental for at least one release to
   allow any issues found by users of the new API to be fixed quickly.

http://dpdk.org/doc/guides/contributing/versioning.html

I'm new to DPDK so I followed this guideline strictly and expect the
maintainers to mark the API stable at some point in the future when they
are happy with it.  Maybe this guideline isn't followed strictly for
librte_vhost?

Thanks for the pointer, it seems it is not strictly followed for
librte_vhost & other libs. Let's keep it experimental for the coming
release.

Maxime

Stefan

Reply via email to