On Mon, Oct 23, 2017 at 10:15:02PM +0200, Thomas Monjalon wrote: > 20/10/2017 14:31, Santosh Shukla: > > Rename buf_physaddr to buf_iovaaddr > > > > Signed-off-by: Santosh Shukla <santosh.shu...@caviumnetworks.com> > > Reviewed-by: Anatoly Burakov <anatoly.bura...@intel.com> > > --- > [...] > > --- a/lib/librte_mbuf/rte_mbuf.h > > +++ b/lib/librte_mbuf/rte_mbuf.h > > @@ -411,7 +411,7 @@ struct rte_mbuf { > > * same mbuf cacheline0 layout for 32-bit and 64-bit. This makes > > * working on vector drivers easier. > > */ > > - iova_addr_t buf_physaddr __rte_aligned(sizeof(iova_addr_t)); > > + iova_addr_t buf_iovaaddr __rte_aligned(sizeof(iova_addr_t)); > > I really do not understand this naming scheme. > The "A" of IOVA means Address. So "addr" in iovaaddr is redundant.
+1 ioaddr looks clearer than iovaaddr. It could also be io_addr or bus_addr. > > It seems that IOVA is a too much famous acronym to avoid it. > Unfortunately, there is no justification in the commit message. > For the record, my preference was "IO address". > > We could at least add an underscore in iova_addr. > > But I will apply it as is because nobody else complained. >