On 9/22/2017 1:25 PM, Pablo de Lara wrote:
In order to improve memory utilization, a single mempool
is created, containing the crypto operation and mbufs
(one if operation is in-place, two if out-of-place).
This way, a single object is allocated and freed
per operation, reducing the amount of memory in cache,
which improves scalability.

Signed-off-by: Pablo de Lara <pablo.de.lara.gua...@intel.com>
---
  app/test-crypto-perf/cperf_ops.c                 |  96 ++++--
  app/test-crypto-perf/cperf_ops.h                 |   2 +-
  app/test-crypto-perf/cperf_test_latency.c        | 361 +++++++++++-----------
  app/test-crypto-perf/cperf_test_pmd_cyclecount.c | 364 +++++++++++-----------
  app/test-crypto-perf/cperf_test_throughput.c     | 358 +++++++++++-----------
  app/test-crypto-perf/cperf_test_verify.c         | 367 +++++++++++------------
  6 files changed, 793 insertions(+), 755 deletions(-)


The patch set looks good to me. Except for one comment in the 6th patch of the series and one comment as below.

Is it possible to move the common code at a single place for all the latency, cycle_count, throughput, verify cases.

I can see a lot of duplicate code in these files.

-Akhil

Reply via email to