Hi Jasvinder, > -----Original Message----- > From: dev [mailto:dev-boun...@dpdk.org] On Behalf Of Jasvinder Singh > Sent: Monday, September 18, 2017 5:10 PM > To: dev@dpdk.org > Cc: Dumitrescu, Cristian <cristian.dumitre...@intel.com>; Yigit, Ferruh > <ferruh.yi...@intel.com>; tho...@monjalon.net > Subject: [dpdk-dev] [PATCH v4 2/4] net/softnic: add traffic management > support > > Add ethdev Traffic Management API support to SoftNIC PMD. > > Signed-off-by: Cristian Dumitrescu <cristian.dumitre...@intel.com> > Signed-off-by: Jasvinder Singh <jasvinder.si...@intel.com> > --- > v3 changes: > - add more confguration parameters (tm rate, tm queue sizes) > > drivers/net/softnic/Makefile | 1 + > drivers/net/softnic/rte_eth_softnic.c | 252 > +++++++++++++++++++++++- > drivers/net/softnic/rte_eth_softnic.h | 16 ++ > drivers/net/softnic/rte_eth_softnic_internals.h | 106 +++++++++- > drivers/net/softnic/rte_eth_softnic_tm.c | 181 +++++++++++++++++ > 5 files changed, 553 insertions(+), 3 deletions(-) create mode 100644 > drivers/net/softnic/rte_eth_softnic_tm.c
> > static void > @@ -293,6 +325,77 @@ rte_pmd_softnic_run_default(struct rte_eth_dev > *dev) > return 0; > } > > +static __rte_always_inline int > +rte_pmd_softnic_run_tm(struct rte_eth_dev *dev) { This function name seems a little misleading. If it's a inline function not an API, better just name it 'softnic_run_tm". And a common comments for the names, like, pmd_feature, tm_params_check, tm_init ... if they're only for soft nic, better add the prefix 'softnc_' for them.