While almost all libraries have the library name match the directory name, some libraries and drivers do not. For those that don't, some have the version filename use the libname, e.g. null_crypto, others have it use the directory name, e.g. ether. Using the library name seems the better standard to follow, so rename rte_ether_version.map to rte_ethdev_version.map.
Signed-off-by: Bruce Richardson <bruce.richard...@intel.com> --- lib/librte_ether/Makefile | 2 +- lib/librte_ether/{rte_ether_version.map => rte_ethdev_version.map} | 0 2 files changed, 1 insertion(+), 1 deletion(-) rename lib/librte_ether/{rte_ether_version.map => rte_ethdev_version.map} (100%) diff --git a/lib/librte_ether/Makefile b/lib/librte_ether/Makefile index db692ae4d..27d9766a8 100644 --- a/lib/librte_ether/Makefile +++ b/lib/librte_ether/Makefile @@ -39,7 +39,7 @@ LIB = librte_ethdev.a CFLAGS += -O3 CFLAGS += $(WERROR_FLAGS) -EXPORT_MAP := rte_ether_version.map +EXPORT_MAP := rte_ethdev_version.map LIBABIVER := 6 diff --git a/lib/librte_ether/rte_ether_version.map b/lib/librte_ether/rte_ethdev_version.map similarity index 100% rename from lib/librte_ether/rte_ether_version.map rename to lib/librte_ether/rte_ethdev_version.map -- 2.13.5