Hi, On Wed, Aug 23, 2017 at 10:00:08PM +0800, Xueming Li wrote: > Currently, enabling assertion have to set CONFIG_RTE_LOG_LEVEL to > RTE_LOG_DEBUG. CONFIG_RTE_LOG_LEVEL is the default log level of control > path, RTE_LOG_DP_LEVEL is the log level of data path. It's a little bit > hard to understand literally that assertion is decided by control path > LOG_LEVEL, especially assertion used on data path. > > On the other hand, DPDK need an assertion enabling switch w/o impacting > log output level, assuming "--log-level" not specified. > > Assertion is an important API to balance DPDK high performance and > robustness. To promote assertion usage, it's valuable to unhide > assertion out of COFNIG_RTE_LOG_LEVEL. > > In one word, log is log, assertion is assertion, debug is hot pot :) > > Rationale of this patch is to introduce an independant switch of > assertion. > > BTW, CONFIG_RTE_LOG_LEVEL is merely a default value of runtime global > log level, not sure the value to keep it in compile time configuration. >
I agree. > Signed-off-by: Xueming Li <xuemi...@mellanox.com> > --- > config/common_base | 1 + > lib/librte_eal/common/include/rte_debug.h | 2 +- > 2 files changed, 2 insertions(+), 1 deletion(-) > > diff --git a/config/common_base b/config/common_base > index 5e97a08b6..ce14b1cac 100644 > --- a/config/common_base > +++ b/config/common_base > @@ -93,6 +93,7 @@ CONFIG_RTE_MAX_NUMA_NODES=8 > CONFIG_RTE_MAX_MEMSEG=256 > CONFIG_RTE_MAX_MEMZONE=2560 > CONFIG_RTE_MAX_TAILQ=32 > +CONFIG_RTE_ASSERTION=n I'm not sure about the name, but I'm not maintainer. I'd suggest something like RTE_ASSERT_ENABLE. > CONFIG_RTE_LOG_LEVEL=RTE_LOG_INFO > CONFIG_RTE_LOG_DP_LEVEL=RTE_LOG_INFO > CONFIG_RTE_LOG_HISTORY=256 > diff --git a/lib/librte_eal/common/include/rte_debug.h > b/lib/librte_eal/common/include/rte_debug.h > index cab6fb4c9..d1104c240 100644 > --- a/lib/librte_eal/common/include/rte_debug.h > +++ b/lib/librte_eal/common/include/rte_debug.h > @@ -79,7 +79,7 @@ void rte_dump_registers(void); > #define rte_panic(...) rte_panic_(__func__, __VA_ARGS__, "dummy") > #define rte_panic_(func, format, ...) __rte_panic(func, format "%.0s", > __VA_ARGS__) > > -#if RTE_LOG_LEVEL >= RTE_LOG_DEBUG > +#ifdef RTE_ASSERTION > #define RTE_ASSERT(exp) RTE_VERIFY(exp) > #else > #define RTE_ASSERT(exp) do {} while (0) > -- > 2.13.3 > Regardless of which name is used: Acked-by: Gaetan Rivet <gaetan.ri...@6wind.com> -- Gaëtan Rivet 6WIND