The code eth_dev->intr_handle = &dev->intr_handle; has duplicate code in the function rte_eth_copy_pci_info(), remove it here.
Signed-off-by: Zhiyong Yang <zhiyong.y...@intel.com> --- lib/librte_ether/rte_ethdev_pci.h | 1 - 1 file changed, 1 deletion(-) diff --git a/lib/librte_ether/rte_ethdev_pci.h b/lib/librte_ether/rte_ethdev_pci.h index c3f7f721c..fe2e0f64c 100644 --- a/lib/librte_ether/rte_ethdev_pci.h +++ b/lib/librte_ether/rte_ethdev_pci.h @@ -117,7 +117,6 @@ rte_eth_dev_pci_allocate(struct rte_pci_device *dev, size_t private_data_size) } eth_dev->device = &dev->device; - eth_dev->intr_handle = &dev->intr_handle; rte_eth_copy_pci_info(eth_dev, dev); return eth_dev; } -- 2.13.3