On Thu, 13 Jul 2017 09:12:31 +0000, Santosh Shukla <santosh.shu...@caviumnetworks.com> wrote: > [PATCH] mempool: add notice to change mempool API/ABI
I think the usual titles for these notices are more: doc: announce API/ABI changes for mempool Ideally, the title should describe more precisely the kind of changes. In that particular case, it looks quite difficult, so just saying "mempool" looks okay. Maybe Thomas will prefer one entry per change, I don't know. > An API/ABI change is planned for 17.11 to change following > > * Remove unused flag param from rte_mempool_generic_get and _put. > * Change data type for mempool 'flag' from int to unsigned int. > Refer [1]. > * Add struct rte_mempool * param into func rte_mempool_xmem_size, > rte_mempool_xmem_usage to make it mempool aware. > Refer [2]. > > [1] http://dpdk.org/dev/patchwork/patch/25603/ > [2] http://dpdk.org/dev/patchwork/patch/25605/ > > Signed-off-by: Santosh Shukla <santosh.shu...@caviumnetworks.com> > --- > doc/guides/rel_notes/deprecation.rst | 8 ++++++++ > 1 file changed, 8 insertions(+) > > diff --git a/doc/guides/rel_notes/deprecation.rst > b/doc/guides/rel_notes/deprecation.rst > index 257dcba32..7abb30f5f 100644 > --- a/doc/guides/rel_notes/deprecation.rst > +++ b/doc/guides/rel_notes/deprecation.rst > @@ -64,3 +64,11 @@ Deprecation Notices > be removed in 17.11: > > - ``rte_eal_parse_devargs_str``, replaced by ``rte_eal_devargs_parse`` > + > +* mempool: The following will be modified in 17.11: I think an empty line is required here, else the generated pdf will be incorrect. > + - ``rte_mempool_xmem_size`` and ``rte_mempool_xmem_usage`` need to know > + the mempool flag status so adding new param rte_mempool in those API. > + - Removing __rte_unused int flag param from ``rte_mempool_generic_put`` > + and ``rte_mempool_generic_get`` API. > + - ``rte_mempool`` flags data type will changed from int to > + unsigned int.