On Fri, 30 Jun 2017 17:51:29 +0100 Ferruh Yigit <ferruh.yi...@intel.com> wrote:
> + > +#ifndef _RTE_UNCI_COMMON_H_ > +#define _RTE_UNCI_COMMON_H_ > + > +#define UNCI_DEVICE "unci" > + > +enum { > + IFLA_UNCI_UNSPEC, > + IFLA_UNCI_PORTID, > + IFLA_UNCI_PID, > + __IFLA_UNCI_MAX, > +}; > + > +#define IFLA_UNCI_MAX (__IFLA_UNCI_MAX - 1) > + > +#endif /* _RTE_UNCI_COMMON_H_ */ > diff --git a/lib/librte_eal/linuxapp/unci/unci_dev.h > b/lib/librte_eal/linuxapp/unci/unci_dev.h > index 0337fa82b..b0a215f1b 100644 > --- a/lib/librte_eal/linuxapp/unci/unci_dev.h > +++ b/lib/librte_eal/linuxapp/unci/unci_dev.h > @@ -26,11 +26,16 @@ > #define _UNCI_DEV_H_ > > #include <linux/netdevice.h> > +#include <exec-env/rte_unci_common.h> > > #ifdef pr_fmt > #undef pr_fmt > #endif > #define pr_fmt(fmt) KBUILD_MODNAME ": " fmt > > +struct unci_dev { > + u8 port_id; > + u32 pid; > +}; These are to/from user space so should be __u8, __u32. Also, probably want to support more than 256 ports at some time in future. So make them both __u32. > > #endif /* _UNCI_DEV_H_ */ Since you want to target this for upstream kernel. Please try and layout the includes in an easy manner to do this and avoid using rte_ in names.