On 21.06.2017 11:58, Bruce Richardson wrote: > On Wed, Jun 21, 2017 at 10:51:58AM +0200, Thomas Monjalon wrote: >> 21/06/2017 10:04, Ilya Maximets: >>> +CONFIG_RTE_LIBRTE_EAL_NUMA_AWARE_HUGEPAGES=n >> >> We can stop inserting LIBRTE in our config options. >> CONFIG_RTE_EAL_ is long enough :) >> > Consistency. While I agree it's unneeded should have it in all or none, > and unless we change a bunch of existing ones, I think it means we have > it in all.
Hmm. There are few options named CONFIG_RTE_EAL_* and CONFIG_RTE_LIBRTE_EAL_*. Also there is one strange CONFIG_RTE_LIBEAL_(USE_HPET). Maybe we can prepare the patch to unify all that options later? Or should I rename CONFIG_RTE_LIBRTE_EAL_NUMA_AWARE_HUGEPAGES to CONFIG_RTE_EAL_NUMA_AWARE_HUGEPAGES in this series?