2017-02-28 05:27, Shreyansh Jain: > From: Ferruh Yigit > > On 2/27/2017 10:01 AM, Shreyansh Jain wrote: > > > On Friday 24 February 2017 03:28 PM, Ferruh Yigit wrote: > > >> We can go with option (1) now, since these are not real APIs to user > > >> application, it can be possible to change them if better solution found. > > >> > > >> Do you think is it good idea to have different naming syntax for those > > >> libraries to clarify they are for PMD internal usage? > > >> > > > > > > Indeed. Current name is librte_common_dpaa2_*. > > > Do you think librte_drvlib_dpaa2 or librte_drvlib_dpaa2_pmd is better? > > > > common vs drvlib may not be different for who don't know about these > > libraries, what about using "internal" or "private" kind of keyword? > > I am ok with librte_pvtlib_dpaa2_pmd or librte_pvtlib_dpaa2. Sounds fine? > ('internal' is too long and its abbreviation 'int' doesn't make it easier > to read. :D )
There is already "lib" in "librte". What about librte_internal_dpaa2_ prefix? Internal is really the best word as you are requesting DPDK to host libraries used only for your drivers. I thought you agreed to host them outside of the DPDK repository. What is your reason to keep pushing in DPDK?