On 2/16/2017 9:26 AM, Thomas Monjalon wrote: > 2017-02-15 15:26, Ferruh Yigit: >> --- a/mk/rte.sdkroot.mk >> +++ b/mk/rte.sdkroot.mk >> @@ -92,8 +92,8 @@ default: all >> config showconfigs showversion showversionum: >> $(Q)$(MAKE) -f $(RTE_SDK)/mk/rte.sdkconfig.mk $@ >> >> -.PHONY: test fast_test ring_test mempool_test perf_test coverage >> -test fast_test ring_test mempool_test perf_test coverage: >> +.PHONY: test test-run fast_test ring_test mempool_test perf_test coverage >> +test test-run fast_test ring_test mempool_test perf_test coverage: >> $(Q)$(MAKE) -f $(RTE_SDK)/mk/rte.sdktest.mk $@ > > "test" is a shortcut for build + basic tests. > I think test-run can be better named. It runs all the basic tests registered > in autotests. "test-all" would be wrong. What about "test-basic"?
Right, "test-basic" matches more to existing rules (test-fast, test-perf, ..), all has hidden "run" action implied, I will use "test-basic" if there is no objection. My concerns is "test-basic" "running basic tests without compilation" may not be obvious for a newcomer. Should I add a line to "make help" for "test" and "test-*" rules? Like: test Compile tests and run basic unit tests test-* Run specific subset of the unit tests thanks, ferruh