On Tue, Jan 31, 2017 at 04:14:33PM +0000, Harry van Haaren wrote: > From: Bruce Richardson <bruce.richard...@intel.com> > > Since the sw driver is a standalone lookaside device that has no HW > requirements, we can provide a set of unit tests that test its > functionality across the different queue types and with different input > scenarios. > > This also adds the tests to be automatically run by autotest.py > > Signed-off-by: Bruce Richardson <bruce.richard...@intel.com> > Signed-off-by: David Hunt <david.h...@intel.com> > Signed-off-by: Harry van Haaren <harry.van.haa...@intel.com> > --- > app/test/Makefile | 5 +- > app/test/autotest_data.py | 26 + > app/test/test_sw_eventdev.c | 2071 > +++++++++++++++++++++++++++++++++++++++++++ > 3 files changed, 2101 insertions(+), 1 deletion(-) > create mode 100644 app/test/test_sw_eventdev.c > > diff --git a/app/test/Makefile b/app/test/Makefile > index e28c079..1770c09 100644 > --- a/app/test/Makefile > +++ b/app/test/Makefile > @@ -197,7 +197,10 @@ SRCS-$(CONFIG_RTE_LIBRTE_CRYPTODEV) += > test_cryptodev_blockcipher.c > SRCS-$(CONFIG_RTE_LIBRTE_CRYPTODEV) += test_cryptodev_perf.c > SRCS-$(CONFIG_RTE_LIBRTE_CRYPTODEV) += test_cryptodev.c > > -SRCS-$(CONFIG_RTE_LIBRTE_EVENTDEV) += test_eventdev.c > +ifeq ($(CONFIG_RTE_LIBRTE_EVENTDEV),y) > +SRCS-y += test_eventdev.c > +SRCS-$(CONFIG_RTE_LIBRTE_PMD_SW_EVENTDEV) += test_sw_eventdev.c
IMO, In order to make symmetrical with cryptodev test cases, We need to change the name to test_eventdev_sw.c Another open question is, Should we allow driver specific test cases? I think, It is OK till we have mature generic unit test cases. Once we have driver specific test case from multiple implementations then we can think of converging all. What you think? > +endif > > SRCS-$(CONFIG_RTE_LIBRTE_KVARGS) += test_kvargs.c