Hi all, while looking at the rte_ring code, I'm wondering if we can simplify that a bit by removing some of the code it in that may not be used. Specifically:
* Does anyone use the NIC stats functionality for debugging? I've certainly never seen it used, and it's presence makes the rest less readable. Can it be dropped? * RTE_RING_PAUSE_REP_COUNT is set to be disabled at build time, and so does anyone actually use this? Can it be dropped? * Who uses the watermarks feature as is? I know we have a sample app that uses it, but there are better ways I think to achieve the same goal while simplifying the ring implementation. Rather than have a set watermark on enqueue, have both enqueue and dequeue functions return the number of free or used slots available in the ring (in case of enqueue, how many free there are, in case of dequeue, how many items are available). Easier to implement and far more useful to the app. Thoughts? Regards, /Bruce