2016-12-23 16:58, Jan Blunck: > +/** > + * @internal > + * Helper macro for drivers that need to convert to struct rte_pci_device. > + */ > +#define RTE_DEV_PCI_DEV(ptr) container_of(ptr, struct rte_pci_device, device)
Do you prefer to rename to RTE_DEV_TO_PCI? > + struct rte_device *device; /**< Backing device for this device */ This comment looks strange. shorten to just "Backing device"?