2016-12-21 16:09, Jan Blunck: > This is a partial merge of Stephens and my patches to make the rte_eth_dev > independent of the rte_pci_device.
Thanks for the hard work. > Jan Blunck (17): > eal: define container_of macro > eal: Allow passing const rte_intr_handle > virtio: Don't fill dev_info->driver_name > virtio: Add vtpci_intr_handle() helper to get rte_intr_handle > virtio: Don't depend on struct rte_eth_dev's pci_dev > bnx2x: localize mapping from eth_dev to pci > fm10k: localize mapping from eth_dev to pci > qede: localize mapping of eth_dev to pci > szedata2: localize handling of pci resources > nfp: localize rte_pci_device handling > vmxnet3: use eth_dev->data->drv_name instead of pci_drv name > ethdev: Helper to map to struct rte_pci_device > drivers: Replace per-PMD macros with rte_eth_dev_to_pci() helper > drivers: Use rte_eth_dev_to_pci() helper > ethdev: Move filling of rte_eth_dev_info->pci_dev to dev_infos_get() > ethdev: Decouple interrupt handling from PCI device > ethdev: Decouple struct rte_eth_dev from struct rte_pci_device > > Stephen Hemminger (6): > rte_device: make driver pointer const > pmd: remove useless reset of dev_info->dev_pci > e1000: localize mapping from eth_dev to pci > ixgbe: localize mapping from eth_dev to pci_device > i40e: localize mapping of eth_dev to pci > broadcom: localize mapping from eth_dev to pci I think it would easier to read if RTE_PCI_DEV macro was introduced at the beginning with container_of macro and used in the "localize patches". So the patches [PATCH v4 19/23] drivers: Replace per-PMD macros with rte_eth_dev_to_pci() helper and [PATCH v4 20/23] drivers: Use rte_eth_dev_to_pci() helper could be squashed in the "localize patches".