> -----Original Message----- > From: dev [mailto:dev-boun...@dpdk.org] On Behalf Of Adrien Mazarguil > Sent: Friday, December 16, 2016 6:25 PM > To: dev@dpdk.org > Subject: [dpdk-dev] [PATCH v2 00/25] Generic flow API (rte_flow) > > As previously discussed in RFC v1 [1], RFC v2 [2], with changes described in > [3] (also pasted below), here is the first non-draft series for this new API. > > Its capabilities are so generic that its name had to be vague, it may be > called > "Generic flow API", "Generic flow interface" (possibly shortened as "GFI") to > refer to the name of the new filter type, or "rte_flow" from the prefix used > for its public symbols. I personally favor the latter. > > While it is currently meant to supersede existing filter types in order for > all > PMDs to expose a common filtering/classification interface, it may eventually > evolve to cover the following ideas as well: > > - Rx/Tx offloads configuration through automatic offloads for specific > packets, e.g. performing checksum on TCP packets could be expressed with > an egress rule with a TCP pattern and a kind of checksum action. > > - RSS configuration (already defined actually). Could be global or per rule > depending on hardware capabilities. > > - Switching configuration for devices with many physical ports; rules doing > both ingress and egress could even be used to completely bypass software > if supported by hardware. > > [1] http://dpdk.org/ml/archives/dev/2016-July/043365.html > [2] http://dpdk.org/ml/archives/dev/2016-August/045383.html > [3] http://dpdk.org/ml/archives/dev/2016-November/050044.html > > Changes since v1 series: > > - Added programmer's guide documentation for rte_flow. > > - Added depreciation notice for the legacy API. > > - Documented testpmd flow command. > > - Fixed missing rte_flow_flush symbol in rte_ether_version.map. > > - Cleaned up API documentation in rte_flow.h. > > - Replaced "min/max" parameters with "num" in struct rte_flow_item_any, > to > align behavior with other item definitions. > > - Fixed "type" (EtherType) size in struct rte_flow_item_eth. > > - Renamed "queues" to "num" in struct rte_flow_action_rss. > > - Fixed missing const in rte_flow_error_set() prototype definition. > > - Fixed testpmd flow create command that did not save the rte_flow object > pointer, causing crashes. > > - Hopefully fixed all the remaining ICC/clang errors. > > - Replaced testpmd flow command's "fix" token with "is" for clarity. > > Changes since RFC v2: > > - New separate VLAN pattern item (previously part of the ETH definition), > found to be much more convenient. > > - Removed useless "any" field from VF pattern item, the same effect can be > achieved by not providing a specification structure. > > - Replaced bit-fields from the VXLAN pattern item to avoid endianness > conversion issues on 24-bit fields. > > - Updated struct rte_flow_item with a new "last" field to create inclusive > ranges. They are defined as the interval between (spec & mask) and > (last & mask). All three parameters are optional. > > - Renamed ID action MARK. > > - Renamed "queue" fields in actions QUEUE and DUP to "index". > > - "rss_conf" field in RSS action is now const. > > - VF action now uses a 32 bit ID like its pattern item counterpart. > > - Removed redundant struct rte_flow_pattern, API functions now expect > struct > rte_flow_item lists terminated by END items. > > - Replaced struct rte_flow_actions for the same reason, with struct > rte_flow_action lists terminated by END actions. > > - Error types (enum rte_flow_error_type) have been updated and the cause > pointer in struct rte_flow_error is now const. > > - Function prototypes (rte_flow_create, rte_flow_validate) have also been > updated for clarity. > > Additions: > > - Public wrapper functions rte_flow_{validate|create|destroy|flush|query} > are now implemented in rte_flow.c, with their symbols exported and > versioned. Related filter type RTE_ETH_FILTER_GENERIC has been added. > > - A separate header (rte_flow_driver.h) has been added for driver-side > functionality, in particular struct rte_flow_ops which contains PMD > callbacks returned by RTE_ETH_FILTER_GENERIC query. > > - testpmd now exposes most of this API through the new "flow" command. > > What remains to be done: > > - Using endian-aware integer types (rte_beX_t) where necessary for clarity. > > - API documentation (based on RFC). > > - testpmd flow command documentation (although context-aware command > completion should already help quite a bit in this regard). > > - A few pattern item / action properties cannot be configured yet > (e.g. rss_conf parameter for RSS action) and a few completions > (e.g. possible queue IDs) should be added. >
Acked-by: Olga Shern <ol...@mellanox.com>