2016-11-10 16:11, Mcnamara, John: > I had a look at the html output before and after this patch and I don't quite > agree with it. I see that you are trying to clean up and make the > documentation more consistent but I don't know if this is the right way to do > it. > > The problem is that TestPMD is a bit of an outlier. It isn't a sample > application and it isn't really a test application despite the name (it is > more of a tester application). Also I don't think that it is a tool/utility > like the other apps in the target directory (if it is seen as a tool then it > should be renamed to something like dpdk-tester for consistency). Testpmd > also has quite a lot of documentation, more than any of our other apps or > utilities, which again makes it an outlier.
Yes testpmd is not the same kind of tool as others. It helps for tests, debugging and demos. About the name, as it is packaged as part of the runtime, I think we should find a better name. As you said it should start with "dpdk-" and it should contain "net" as it does not test the crypto drivers. Something like dpdk-testpmd-net. > So my preference is to leave TestPMD in the high level index. OK I understand your opinion. > However, I do think the High level index should be cleaned up a bit and the > items re-ordered into a more logical sequence. I'll submit a patch for that. OK thanks