The current test_pci is just a single test case that tests the blacklisting of devices. Rename it to test_pci_blacklist and call it from the test_pci. The setup and cleanup are moved out of the test_pci_blacklist entirely to cover all other tests.
Signed-off-by: Jan Viktorin <viktorin at rehivetech.com> --- v4 * the definitions of setup and cleanup functions are NOT moved (T. Monjalon) --- app/test/test_pci.c | 19 ++++++++++++++----- 1 file changed, 14 insertions(+), 5 deletions(-) diff --git a/app/test/test_pci.c b/app/test/test_pci.c index 50078a0..28d710b 100644 --- a/app/test/test_pci.c +++ b/app/test/test_pci.c @@ -178,17 +178,14 @@ test_pci_cleanup(void) return 0; } -int -test_pci(void) +static int +test_pci_blacklist(void) { struct rte_devargs_list save_devargs_list; printf("Dump all devices\n"); rte_eal_pci_dump(stdout); - if (test_pci_setup()) - return -1; - rte_eal_pci_register(&my_driver); rte_eal_pci_register(&my_driver2); @@ -224,6 +221,18 @@ test_pci(void) rte_eal_pci_unregister(&my_driver); rte_eal_pci_unregister(&my_driver2); + return 0; +} + +int +test_pci(void) +{ + if (test_pci_setup()) + return -1; + + if (test_pci_blacklist()) + return -1; + if (test_pci_cleanup()) return -1; -- 2.8.0