> -----Original Message----- > From: Yigit, Ferruh > Sent: Friday, July 22, 2016 2:19 PM > To: De Lara Guarch, Pablo; dev at dpdk.org; Mcnamara, John > Subject: Re: [dpdk-dev] [PATCH] doc: announce driver name changes > > On 7/22/2016 1:54 PM, Adrien Mazarguil wrote: > > Hi Pablo, > > > > On Fri, Jul 22, 2016 at 12:37:22PM +0000, De Lara Guarch, Pablo wrote: > >> Hi, > >> > >>> -----Original Message----- > >>> From: De Lara Guarch, Pablo > >>> Sent: Saturday, July 09, 2016 5:57 PM > >>> To: dev at dpdk.org > >>> Cc: Mcnamara, John; De Lara Guarch, Pablo > >>> Subject: [PATCH] doc: announce driver name changes > >>> > >>> Driver names for all the supported devices in DPDK do not have > >>> a naming convention. Some are using a prefix, some are not > >>> and some have long names. Driver names are used when creating > >>> virtual devices, so it is useful to have consistency in the names. > >>> > >>> Signed-off-by: Pablo de Lara <pablo.de.lara.guarch at intel.com> > >>> --- > >>> doc/guides/rel_notes/deprecation.rst | 5 +++++ > >>> 1 file changed, 5 insertions(+) > >>> > >>> diff --git a/doc/guides/rel_notes/deprecation.rst > >>> b/doc/guides/rel_notes/deprecation.rst > >>> index f502f86..37d65c8 100644 > >>> --- a/doc/guides/rel_notes/deprecation.rst > >>> +++ b/doc/guides/rel_notes/deprecation.rst > >>> @@ -41,3 +41,8 @@ Deprecation Notices > >>> * The mempool functions for single/multi producer/consumer are > >>> deprecated and > >>> will be removed in 16.11. > >>> It is replaced by rte_mempool_generic_get/put functions. > >>> + > >>> +* Driver names are quite inconsistent among each others and they will > be > >>> + renamed to something more consistent (net_ prefix for net drivers and > >>> + crypto_ for crypto drivers) in 16.11. Some of these driver names are > used > >>> + publicly, to create virtual devices, so a deprecation notice is > >>> necessary. > >>> -- > >>> 2.7.4 > >> > >> Any more comments on this (apart from Christian Ehrhardt's)? > > > > Yes, since you're suggesting to prefix driver names, shall "librte_pmd_mlx5" > > really become "net_librte_pmd_mlx5" or shortened to "net_mlx5" instead? > > > > What about using a '/' separator instead of '_'? > > > > Will this impact directories as well ("net/mlx5" -> "net/net_mlx5")? > >
We will leave these untouched, although I don't think renaming the directories was necessary. > > For physical net devices, driver name is same as folder name (mlnx5, > ixgbe ...) > > For virtual net devices, driver name is folder name with "eth_" prefix > (eth_pcap, eth_ring) > > Driver names for net devices looks consistent already, I don't know > about crypto devices but if crypto driver names are inconsistent what do > you think renaming crypto drivers only? Sure, as long as virtual Ethernet devices are consistent, I think it is ok. My main intention here was to have consistent (and short) driver names, to call rte_eal_vdev_init (or --vdev in command line). Thanks, Pablo > > Thanks, > ferruh