On Mon, Jan 04, 2016 at 09:08:15PM +0100, Jan Viktorin wrote: > The union rte_device can be used in situations where we want to work with all > devices without distinguishing among bus-specific features (PCI, ...). > The target device type can be detected by reading the magic. > > Also, the macros RTE_DEVICE_DECL and RTE_DEVICE_PTR_DECL are introduced to > provide a generic way to declare a device or a pointer to a device. The macros > aim to preserve API backwards-compatibility. Eg. > > struct old_super_struct { => struct old_super_struct { > struct rte_pci_device *pci_dev; => RTE_DEVICE_PTR_DECL(pci_dev); > ... => ... > }; => }; > > struct old_super_struct inst; > > The new code should reference inst.dev.pci, the old code can still use the > inst.pci_dev. The previously introduced magic is included so one can ask the > instance about its type: > > if (inst.dev.magic == RTE_PCI_DEVICE_MAGIC) { > ... > }
Rather than magic numbers i.e. #defines, an enum might be better. /Bruce