On Mon, Feb 15, 2016 at 02:24:25PM +0100, David Marchand wrote: > +/** > + * A structure used to access io resources for a pci device. > + * rte_pci_ioport is arch, os, driver specific, and should not be used > outside > + * of pci ioport api. > + */ > +struct rte_pci_ioport { > + struct rte_pci_device *dev; > + uint64_t offset; > +};
"offset" dosen't sound like a good name to me; espeicially when I found code like below: reg = p->offset + offset; Regarding that, maybe "base" is a better name? I don't like it too much, though. Any better idea? Otherwise, this patch looks good to me. --yliu