Bulk requests to get or put objects in a mempool often vary in size.
A series of tests with pseudo random request sizes, to mitigate the
benefits of the CPU's dynamic branch predictor, was added.

Also, various other minor changes:
- Improved the output formatting for readability.
- Added test for the "default" mempool with cache.
- Skip the tests for the "default" mempool, if it happens to use the same
  driver (i.e. operations) as already tested.
- Replaced bare use of "unsigned" with "unsigned int",
  to make checkpatches happy.

v2:
* Split patch into individual patches. (Andrew Rybchenko)

Morten Brørup (4):
  mempool perf test: replace bare unsigned with unsigned int
  mempool perf test: test default mempool with cache
  mempool perf test: improve output readability
  mempool perf test: test random bulk sizes

 app/test/test_mempool_perf.c | 222 +++++++++++++++++++++++++++--------
 1 file changed, 173 insertions(+), 49 deletions(-)

-- 
2.43.0

Reply via email to