On Thu, Feb 06, 2025 at 12:54:24PM +0200, Shani Peretz wrote:
> When registering a new PCI device, the device->name field stored
> the user-provided string from devargs (e.g., "08:00.0" or "0000:08:00.0").
> This approach led to inconsistencies when registering new devices.
> 
> This patch fix this issue by saving the parsed PCI in device->name,
> so when a new PCI device is registering the name displayed in the device
> list will be the parsed version.
> 
> Fixes: 23eaa9059ec2 ("bus/pci: use given name as generic name")
> 
> Cc: sta...@dpdk.org
> Signed-off-by: Shani Peretz <shper...@nvidia.com>
> ---
>  drivers/bus/pci/pci_common.c | 14 ++------------
>  1 file changed, 2 insertions(+), 12 deletions(-)
> 
Tested-by: Bruce Richardson <bruce.richard...@intel.com>

Tested with running testpmd using -a 27:00.0 -a 27:00.1 and then using
dpdk-proc-info with the same ports prefixed with 0000:. Without this patch,
that gave an error. With this patch, output was the same with and without
the extra prefix.
Also tested the reverse case, running testpmd with the domain prefix, and
proc-info without, that too worked in testing.

/Bruce

Reply via email to