Already reviewed before.
Acked-by: Huisong Li <lihuis...@huawei.com>


在 2024/10/23 13:11, Sivaprasad Tummala 写道:
This patch refactors the power management library, addressing uncore
power management. The primary changes involve the creation of dedicated
directories for each driver within 'drivers/power/uncore/*'. The
adjustment of meson.build files enables the selective activation
of individual drivers.

This refactor significantly improves code organization, enhances
clarity and boosts maintainability. It lays the foundation for more
focused development on individual drivers and facilitates seamless
integration of future enhancements, particularly the AMD uncore driver.

v9:
  - documentation update

v8:
  - removed c++ guards for internal header files
  - renamed rte_power_uncore_ops.h for naming convention

v7:
  - fixed build error with aarch32 gcc cross compilation

v6:
  - fixed compilation error with symbol export in API

v5:
  - fixed build errors for risc-v/ppc targets

v4:
  - fixed build error with RTE_ASSERT

Signed-off-by: Sivaprasad Tummala <sivaprasad.tumm...@amd.com>
---
  doc/guides/prog_guide/power_man.rst           |  10 +-
  .../power/intel_uncore/intel_uncore.c         |  18 +-
  .../power/intel_uncore/intel_uncore.h         |   9 +-
  drivers/power/intel_uncore/meson.build        |   6 +
  drivers/power/meson.build                     |   3 +-
  lib/power/meson.build                         |   2 +-
  lib/power/power_uncore_ops.h                  | 244 +++++++++++++++++
  lib/power/rte_power_uncore.c                  | 256 +++++++++---------
  lib/power/rte_power_uncore.h                  |  61 ++---
  lib/power/version.map                         |   1 +
  10 files changed, 440 insertions(+), 170 deletions(-)
  rename lib/power/power_intel_uncore.c => 
drivers/power/intel_uncore/intel_uncore.c (95%)
  rename lib/power/power_intel_uncore.h => 
drivers/power/intel_uncore/intel_uncore.h (97%)
  create mode 100644 drivers/power/intel_uncore/meson.build
  create mode 100644 lib/power/power_uncore_ops.h
<snip>

Reply via email to