This patchset performs two cleanups: 1. Four functions in ethdev.c which were enabled for debug only have been merged into their inlined header-file counterparts. This change required that a number of macros be renamed and moved to the header file too. The macro changes are in patches 1 & 2, and the elimination of the separate debug fns are in patch 3. 2. Checks for valid function pointers are added to the API calls for reading the descriptor ring count, and checking for a valid descriptor. This is because these functions are not implemented by most drivers, and so it's far safer to have the check.
--- V2 Changes: * Rebased to latest DPDK codebase * Changed type from uint32_t to int for the count function, on the basis of feedback received. Bruce Richardson (4): ethdev: rename macros to have RTE_ETH prefix ethdev: move error checking macros to header ethdev: remove duplicated debug functions ethdev: check driver support for functions lib/librte_ether/rte_ethdev.c | 674 ++++++++++++++++++------------------------ lib/librte_ether/rte_ethdev.h | 121 ++++++-- 2 files changed, 375 insertions(+), 420 deletions(-) -- 2.4.3