On 2024-10-15 09:39, Morten Brørup wrote:
From: Mattias Rönnblom [mailto:hof...@lysator.liu.se]
Sent: Tuesday, 15 October 2024 09.11
On 2024-10-15 08:41, Mattias Rönnblom wrote:
On 2024-10-14 10:17, Morten Brørup wrote:
Please remove the _VALUE suffix.
You changed your mind? I'm missing the rationale here.
Yes, I changed my mind.
Please revisit the discussion regarding patch v9.
I supposed this is a bit of subjective hairsplitting, but does anyone
else have an opinion?
Short versus somewhat more readable name.
Thomas also suggested using shorter names, specifically renaming
rte_lcore_var_lcore_ptr() to rte_lcore_var().
I would interpret that feedback as a request to shorten the macro names too.
If nobody objects I will change the names of the macros, and the
above-mentioned function as well.
To get "your own" value should be something like
struct foo *lcore_foo = RTE_LCORE_VAR(foo);
versus
struct foo *lcore_foo = RTE_LCORE_VAR_VALUE(foo);
We should also strip "_VALUE" off of the RTE_LCORE_FOREACH_VALUE()
macro
name in case we change the names of the access macros.
Agree. Remove "_VALUE" everywhere in the API.