This patch series aims to add two commands for the testpmd application:
- testpmd> set port <port-id> eeprom <accept_risk> magic <magic> \
          value <value> offset <offset>
- testpmd> set port <port-id> led <on/off>

---
v5:
* Use 'accept_risk' rather than 'confirm' to make it clear enough.
* Use dynamic memory alloc rather than VLA.
* Place the logic in the right place following the reviewer's request.
v4:
* Make the log more readable by using 'rte_strerror()'.
* Make the modification of document following the rules.
v3:
* Add acknowledgement for the set eeprom command.
* Modify logic following the request from reviewer.
v2:
* Solve the conflict in document file.
---

James Hershaw (2):
  app/testpmd: add support for setting device EEPROM
  app/testpmd: add set dev led on/off command

 app/test-pmd/cmdline.c                      | 179 ++++++++++++++++++++
 app/test-pmd/config.c                       |  59 +++++++
 app/test-pmd/testpmd.h                      |   3 +
 doc/guides/testpmd_app_ug/testpmd_funcs.rst |  25 +++
 4 files changed, 266 insertions(+)

-- 
2.39.1

Reply via email to