Actually, I do have one thought.

On Tue, Oct 8, 2024 at 4:45 PM Nicholas Pratte <npra...@iol.unh.edu> wrote:

> +    def set_mac_addr(self, port_id: int, mac_address: str, add: bool,
> verify: bool = True) -> None:
> +        """Add or remove a mac address on a given port's Allowlist.
> +
> +        Args:
> +            port_id: The port ID the mac address is set on.
> +            mac_address: The mac address to be added to or removed from
> the specified port.
> +            add: If :data:`True`, add the specified mac address. If
> :data:`False`, remove specified
> +                mac address.
>

Should we replace "add" with "set" or an equivalent? Add=True means add.
Add=false doesn't necessarily mean remove... set=True and set=False reads a
little clearer for a function where the boolean is adding/removing
something. But, it's just a thought - add is probably fine if you think
that that's what reads best.

Reply via email to