create mode 100644 dts/execution_conf.yaml

As Jeremy mentioned, this is a duplicate. I guess this patch needs to be rebased as it mentions executions all over the place.

  create mode 100644 dts/node_conf.yaml
  create mode 100644 dts/testbed_conf.yaml

And this should be named test_run_conf.yaml or testrun_conf.yaml (it's not just testbed conf, but also other things used in test runs). Or maybe we can come up with an abbreviation or initialism for test run.

diff --git a/dts/framework/config/__init__.py b/dts/framework/config/__init__.py
index df60a5030e..2322f3d996 100644
--- a/dts/framework/config/__init__.py
+++ b/dts/framework/config/__init__.py
@@ -573,29 +573,39 @@ def from_dict(cls, d: ConfigurationDict) -> Self:
          return cls(test_runs=test_runs)
-def load_config(config_file_path: Path) -> Configuration:
+def load_config(node_config_file_path: Path, exec_config_file_path: Path) -> 
Configuration:
      """Load DTS test run configuration from a file.
- Load the YAML test run configuration file
+    Load both the YAML testbed and execution configuration files
      and :download:`the configuration file schema <conf_yaml_schema.json>`,
-    validate the test run configuration file, and create a test run 
configuration object.
+    validate both configuration files to create a test run configuration 
object.

Now that you're removed the last "and" the sentence feels like it's missing something. If we add then to "then validate both" then it sounds fine.


diff --git a/dts/framework/config/conf_yaml_schema.json 
b/dts/framework/config/conf_yaml_schema.json
index f02a310bb5..1962ed05dd 100644
--- a/dts/framework/config/conf_yaml_schema.json
+++ b/dts/framework/config/conf_yaml_schema.json
@@ -211,192 +211,192 @@

+  "oneOf": [

Again, as mentioned in the other comment, splitting the schema would make more sense. We'd probably have to make some doc modifications (in guides/tools/dts.rtst)



Reply via email to