> From: Bruce Richardson [mailto:bruce.richa...@intel.com] > > There are a number of issues with the current RTE_MAX_QUEUES_PER_PORT > setting in DPDK that are addressed by this patchset: > > * The name does not make it clear that this is intended as an > ethdev-only setting > * A number of other libraries are using this define rather than having > more relevant defines for the particular usecase. > * The define is hard-coded in DPDK source code and is not adjustable via > a build-time/meson option > * Because of the lack of configurability, the max is therefore set to a > conservatively-high value, wasting memory. > * There is an assumption that the number of Rx queues and Tx queues > should have the same maximum value. Depending on application, it may > be desirable to have fan-in with multiple Rx queues e.g. for > classification/filtering, feed a single Tx queue, or the opposite > where, e.g. for QoS Tx scheduling, a few Rx queues feeds a very large > number of Tx queues. > > This patchset therefore addresses these by: > > * replacing the single define for max queues with independent defines > for Rx and Tx queues. > * adjusts the name to ensure that it is clear the defines are for > ethports only. [ethports being used in the RTE_MAX_ETHPORTS setting]. > * replaces occurances of RTE_MAX_QUEUES_PER_PORT with appropriate > defines for non-ethdev use cases > * replaces all other internal occurances of the define with the new > per-Rx and per-Tx definitions. > * adds meson config options to allow build-time configuration of the max > Rx and Tx queue values. > > Naming Note: > * The new meson config options are called "max_ethport_rx_queues" and > "max_ethport_tx_queues" so that in the meson options list they appear > alphabetically beside the existing "max_ethports" option. > * For naming consistency, the new C defines are therefore > RTE_MAX_ETHPORT_RX_QUEUES and RTE_MAX_ETHPORT_TX_QUEUES. > > V2: > * What was a single patch with "3 insertions(+), 1 deletion(-)" has now > become a 26-patch set! :-) > * Created separate Rx and Tx defines > * Ensured that the name makes it clear that the define is for ethdev > * When updating internal use, created one patch per component for easier > maintainer review. In most cases it was obvious whether Rx or Tx > define should be used, but a few cases were less clear. > * Added documentation updates for the changes (release notes and > deprecation notice), spread across 3 of the patches.
Thanks. For the series, Acked-by: Morten Brørup <m...@smartsharesystems.com>