On Wed, Feb 28, 2024 at 6:59 PM Tyler Retzlaff
<roret...@linux.microsoft.com> wrote:
> > I find this new helper less tricky to use and easier to read than the
> > RTE_FMT_* stuff that gets copy/pasted everywhere.
> > The changes are quite mechanical, so even though we are past -rc1, +1
> > for me on the series.
> >
> > Can we finish the job and convert remaining macros that prefix messages in 
> > lib/?
>
> I didn't realize I missed any. do you have a list or a regex that points
> me at them.  I was just searching for use of args...
>
> Happy to make the conversion of the others in the next rev.

Basically, this new macro/approach makes direct use of RTE_FMT_HEAD unneeded.

So I grepped like this:
$ git grep RTE_FMT_HEAD -- lib/ :^lib/log/ :^lib/eal/include/rte_common.h
b55361f252:lib/cryptodev/rte_cryptodev.h:               RTE_FMT("%s()
line %u: " RTE_FMT_HEAD(__VA_ARGS__ ,), \
b55361f252:lib/cryptodev/rte_cryptodev.h:               RTE_FMT("%s()
line %u: " RTE_FMT_HEAD(__VA_ARGS__ ,), \
b55361f252:lib/cryptodev/rte_cryptodev.h:               RTE_FMT("[%s]
%s: " RTE_FMT_HEAD(__VA_ARGS__ ,), \
b55361f252:lib/eal/windows/include/rte_windows.h:
RTE_FMT_HEAD(__VA_ARGS__ ,), GetLastError(), \
b55361f252:lib/eventdev/eventdev_pmd.h:         RTE_FMT("%s() line %u:
" RTE_FMT_HEAD(__VA_ARGS__ ,), \
b55361f252:lib/eventdev/eventdev_pmd.h:         RTE_FMT("%s() line %u:
" RTE_FMT_HEAD(__VA_ARGS__ ,), \
b55361f252:lib/eventdev/rte_event_timer_adapter.c:
RTE_FMT("EVTIMER: %s() line %u: " RTE_FMT_HEAD(__VA_ARGS__ ,), \
b55361f252:lib/graph/graph_private.h:           RTE_FMT("%s():%u "
RTE_FMT_HEAD(__VA_ARGS__ ,),                \
b55361f252:lib/member/member.h:         RTE_FMT("%s(): "
RTE_FMT_HEAD(__VA_ARGS__ ,), \
b55361f252:lib/node/node_private.h:             RTE_FMT("%s: %s():%u "
RTE_FMT_HEAD(__VA_ARGS__ ,),            \


-- 
David Marchand

Reply via email to