On Fri, Feb 23, 2024 at 8:19 PM Luca Vizzarro <luca.vizza...@arm.com> wrote: > > On 29/01/2024 13:10, Juraj Linkeš wrote: > > Here's I'd add logged additionally as an error, as this sounds as if > > we're changing debug to error > > That is also a way of doing this, but an error is an error. If we wanted > to log the same thing in debug and error, then when we go read the debug > we get duplicates... making it less readable. What do you say? >
I meant let's change the commit message wording to better reflect what the patch does - it adds stderr to the exception, not doing something instead of logging it as debug (it could be understood this way). But it doesn't really matter much. Maybe a better wording of the second sentence would be "So that, instead of logging it just as debug, it is also stored in an error, ." > > I'd change the order here (and all other places) so that stderr is > > before the return code. > Ack. > > > We should mention that the last string is the stderr output. Maybe we > > just add 'Stderr:' before {self._command_stderr}. And maybe we should > > put quotes around {self._command_stderr}. > > Since you mentioned "quotes", I'd think that it'd be even better to > indent it as if it's a quote. With logs as busy as the ones DTS prints, > adding some quotes may not change much as it's all already very crowded. > Can prefix with 'Stderr: ' though. The prefix is essential so that we know what the output actually is. Indenting it sounds great.