Hi Ferruh, On 2024/1/11 19:11, Ferruh Yigit wrote: > On 1/11/2024 1:55 AM, fengchengwen wrote: >> Hi Ferruh, >> >> On 2024/1/10 20:15, Ferruh Yigit wrote: >>> On 1/10/2024 1:38 AM, fengchengwen wrote: >>>> Hi Ferruh, >>>> >>>> On 2024/1/10 2:06, Ferruh Yigit wrote: >>>>> On 1/9/2024 2:19 AM, Jie Hai wrote: >>>>>> On 2023/12/14 20:49, Ferruh Yigit wrote: >>>>>>> On 12/14/2023 1:56 AM, Jie Hai wrote: >>>>>>>> The ethdev library now registers a telemetry command for >>>>>>>> dump regs. >>>>>>>> >>>>>>>> An example usage is shown below: >>>>>>>> --> /ethdev/regs,test >>>>>>>> { >>>>>>>> "/ethdev/regs": { >>>>>>>> "regs_offset": 0, >>>>>>>> "regs_length": 3192, >>>>>>>> "regs_width": 4, >>>>>>>> "device_version": "0x1080f00", >>>>>>>> "regs_file": "port_0_regs_test" >>>>>>>> } >>>>>>>> } >>>>>> >>>>>>> >>>>>>> Above code writes register data to a file. >>>>>>> >>>>>>> I am not sure about this kind of usage of telemetry command, that it >>>>>>> cause data to be written to a file. >>>>>>> >>>>>>> My understanding is, telemetry usage is based on what telemetry client >>>>>>> receives. >>>>>>> What do you think just keep the 'reg_info' fields excluding data to the >>>>>>> file? >>>>>>> >>>>>>> .Hi, Ferruh >>>>>> >>>>>> I tried to write all register information to telemetry data, >>>>>> but gave up because some drivers had too many registers (eg.ixgbe) >>>>>> to carry. Therefore, the writing data to file approach is selected. >>>>>> >>>>>> When we query a register, the register content is the key. >>>>>> The information such as the width and length is only auxiliary >>>>>> information. If the register data cannot be obtained, the auxiliary >>>>>> information is optional. So I don't think register data should be >>>>>> removed. >>>>>> >>>>>> In my opinion, writing a file is a more appropriate way to do it. >>>>>> I wonder if there's a better way. >>>>>> >>>>>> >>>>> >>>>> Is there a usecase to get register information from telemetry interface? >>>> >>>> Among the available tools: >>>> 1, ethtool/proc-info: should use multi-process mechanism to connect to the >>>> main process >>>> 2, telemetry: easier, lighter load, and it don't need re-probe the ethdev >>>> in the secondary process, >>>> and also cost more resource, like hugepage, cores. >>>> >>>> From our users, they prefer use the second 'telemetry', so I think we >>>> should move >>>> more status-query-points to telemetry. >>>> >>>> As for this question, I think it's okay to get register info from >>>> telemetry. >>>> >>>> >>>> >>>> Another question, we have some internal registers, which: >>>> 1. Is not suitable expose by xstats, because they may includes >>>> configuration >>>> 2. Is not suitable expose by dumps, because this dumps is hard to >>>> understand (because it only has value). >>>> >>>> So we plan to add some telemetry points in the driver itself, so we could >>>> display them like xstats: >>>> "xxxx" : 0x1234 >>>> "yyyy" : 0x100 >>>> >>>> Will the community accept this kind of telemetry points which limit one >>>> driver ? >>>> >>> >>> Hi Chengwen, >>> >>> I see there is a usecase/requirement. >>> >>> With this patch, even using file, only register values are dumped and >>> isn't it hard to find value of specific register? >>> >>> ("xxxx" : 0x1234) approach looks better, but instead of making this >>> telemetry support for specific driver, what about making it in two steps. >>> >>> First add new dev_ops, (or update existing one), to get registers with >>> "name: value" format, (in a way to allow empty name), or even perhaps >>> "name: offset, value" format. >>> And in second stage add telemetry support around it. >>> (Name being optional lets us wrap exiting 'get_reg' dev_ops with new one) >>> >>> When adding dev_ops, it may get an additional 'filter' parameter, to get >>> only subset of regs, like "mac*" to get regs name staring with "mac", >>> this may help for the cases there are too many registers you mentioned. >>> >>> Anyway, we can discuss more about its design, but what do you think >>> about first having a dev_ops for this? >> >> I prefer extend struct rte_dev_reg_info, like this: >> >> struct rte_eth_reg_name { >> char name[RTE_ETH_REG_NAME_SIZE]; >> }; >> >> struct rte_dev_reg_info { >> void *data; /**< Buffer for return registers */ >> uint32_t offset; /**< Start register table location for access */ >> uint32_t length; /**< Number of registers to fetch */ >> uint32_t width; /**< Size of device register */ >> uint32_t version; /**< Device version */ >> /* Note: below two fields are new added. */ >> char *filter; /**< Filter for target subset of registers. This field >> could affects register selection for data/length/name. */ >> struct rte_eth_reg_name *names; /**< Registers name saver. */ >> }; >> > > ack > >> For driver which don't identify the new filter and names fields: >> 1. .get_reg return the all registers value. >> > > ack > > >> 2. and driver will not touch the name fields. >> 3. rte_eth_dev_get_reg_info() could detect name fileds not filled, and >> then it fill with default names, e.g. offset-1/offset-2/... >> > > Is there a benefit to provide default names? API can clear the 'names' > buffer, and driver may or may not fill it. If names not filled, API > behaves like existing one, it will just provide register values.
ok > > >> For driver which identify the new filter and names fields: >> 1. rte_eth_dev_get_reg_info() will return filtered register's value and >> also their names. >> > > ack > >> So that those which invoke rte_eth_dev_get_reg_info() could extra prepare >> names, and it call the same API will get data and name. >> >> >> Add one new .get_reg_name ops and corresponding API like: >> rte_eth_dev_get_reg_name() could also feasible. >> But I think the rte_eth_dev_get_reg_info()'s name is too broad, the info >> could includes value and also it's name. >> So I prefer not add one new ops. >> > > ack > >> >> Another question? what are the supported values of filters ? >> I prefer report by dev_info ops, something like a string array end with NULL. >> Use could query from rte_eth_dev_info_get API. >> > > I don't think there is a need to populate predefined filter list, it can > be free text with simple '*' and '.' wildcard support and ',' to support > list of text. > > User may get full list first, later can filter the ones they are interested. > Like: "*mac*,*rss*" can match all register names that has 'mac' and > 'rss' in it. ok. Our team will send v1 ASAP. Thanks. > > . >