On Fri, 8 Dec 2023 15:59:44 +0100 David Marchand <david.march...@redhat.com> wrote:
> Add the device name as a prefix of logs associated to madvise() calls. > > Signed-off-by: David Marchand <david.march...@redhat.com> > --- > lib/vhost/iotlb.c | 18 +++++++++--------- > lib/vhost/vhost.h | 2 +- > lib/vhost/vhost_user.c | 26 +++++++++++++------------- > 3 files changed, 23 insertions(+), 23 deletions(-) The logging part looks good, but looking at the code, the function mem_set_dump() has some things that should be addressed. Since it is global (but not exported) function the function name may potentially clash when used with static linkage. It should be renamed. Code is duplication of eal_mem_set_dump(). Would be better to have one version. Maybe rte_eal_mem_set_dump()? Acked-by: Stephen Hemminger <step...@networkplumber.org>